Unable to access my.storefeeder.com
Incident Report for StoreFeeder
Resolved
This incident has been resolved.
Posted Jun 23, 2022 - 20:46 BST
Investigating
Our monitoring has picked up that some users are unable to access my.storefeeder.com, our engineers are looking into this and will provide updates to when the system will be functioning as expected.
Posted Jun 23, 2022 - 20:22 BST
This incident affected: StoreFeeder Main System.