Amazon Web Services (AWS) outage

Incident Report for StoreFeeder

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:58 BST

Monitoring

AWS started slowly recovering their services. Our team continues to monitor the situation.
Posted Oct 20, 2025 - 10:49 BST

Investigating

We’re aware of a major Amazon Web Services (AWS) outage currently affecting a range of online services, including couriers, marketplaces, and webstores. (https://www.bbc.co.uk/news/live/c5y8k7k6v1rt?app-referrer=push-notification)

Please note that StoreFeeder itself is not directly affected, but because we connect to external systems which could be, you may experience issues including, but not limited to:

- Shipping labels not being generated
- Updates to sales channels failing
- Error messages appearing when communicating with couriers or marketplaces
- Connections to accounting platforms (Xero etc)

These issues are beyond our control and depend on when each affected service restores normal operation.

We’ll continue to monitor the situation closely.

Thank you for your patience and understanding.
Posted Oct 20, 2025 - 10:49 BST
This incident affected: Other.