Reports of system slowness

Incident Report for StoreFeeder

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 12:24 BST

Update

The issue has been resolved and we are currently monitoring.
Posted Oct 06, 2025 - 11:39 BST

Identified

We have identified an external issue with one of our databases,

We are working on this, and it should be resolved very soon.
Posted Oct 06, 2025 - 11:19 BST

Investigating

We have had some reports of slowness of the system affecting some of our users.

We are aware of the issue and we are investigating as a matter of urgency. If this is affecting you, there is no need to contact support.

We will keep this page live with updates.
Posted Oct 06, 2025 - 11:15 BST
This incident affected: StoreFeeder Main System.